Episode 32: Rock solid WiFi for home automation, part 1

#1

Ep 32 is up, and I’m working on part 2 now which will cover VLANs and other interesting things:

2 Likes
#2

Hi Jon,

Excellent, just what I have been looking for.
I have followed your setup ( I am in Australia)
But have a two of issues
I have my Telephone through the router Telstra Smart Modem Gen 2, Arcadyan LH1000.
When put into Bridge Mode I loose my telephone.
I have installed the software on a Synology box in Docker, software works
Connect as per video, log back into software, the Unifi has a steady light, but cannot be found.
Any suggestions Len

#3

Hi Len, welcome to the forum!

You’re right, putting the router into bridge mode will disable the phone connection through it. The Arcadyan LH1000 has a built-in ATA/VoIP adapter which is what provides the phone socket on the back. Those adapters are also commonly available as a stand-alone item: I have one that I haven’t used for years, so I could send it to you if you like.

However, I don’t know if that will solve your problem. If Telstra have provided you details of the phone configuration for your current router, you should be able to put those same details into another ATA/VoIP adapter and plug it into your network.

When you say “the UniFi has a steady light”, what device do you mean? Do you have a UniFi access point?

#4

Hi John,

Thank you for the quick reply.

Over the years I have been keen on Home Automation, especially after finding your YouTube channels, which encouraged me to become a Pateron member.

I purchased a UniFi Security Gateway last year but could not get it to work.

I have progressed this year to being able to Tasmota some Sonoffs etc.

Found the new Home Assistant and wanted a more secure network.

Your video has come at the right time.

The connection was as per your video into the UniFi Gateway, that is were I lost the telephone.

I put the UniFi software on a separate computer running a Disk Station NAS, placing the software in a Docker.
I was able to open the software and follow your instruction.

The UniFi gateway flashed for a minute or two, then went solid, (the square on top of the unit)

Back into the software, “No Device” found, (following the video)

Rebooted both UniFi Gateway and Browser, solid light but still no device found.
I would like to take your kind offer for the VOIP if I can get it working.
As you rightly say, security is paramount.

Regards Len

1 Like
#5

I loved the video! Singing the truth :laughing:

I went the route of the Lite version and I did not do the gateway because I am running a dedicated PfSense box. I did however install the software on the computer I am running Plex on since it is idle more often than streaming and it is AWESOME!!! I find it funny that I can see all the people that drive by on the highway past one of the AP’s by the gate. I get a LONG list of unique ID’s that it catches briefly. Lots of them phones, some of them mobile AP’s, some even car systems that act as AP’s. The stats that that system generates is staggering and I enjoy perusing through it.

I have 3 of them scattered across my 5 acre property and the range is unbelievable. 1 is mounted inside a metal cabinet, one in a plastic demark box on the back of my power panel (Stage Coach Stop) and the other in the house on the wall of my lab space which is centrally located in the structure. I can cover the entirety of the 5 acres and get a decent signal with a flawless handoff. I round filed the old routers and will never look back. Worth EVERY dollar.

#6

@Len, when the USG goes to a solid light, what colour is it? If the light goes solid blue that means it thinks it’s been adopted by a controller, and everything is good.

It’s possible that the USG has been adopted by a different controller previously. Once it’s been adopted, it won’t allow itself to be linked to a different controller. For example, if you do a test installation of the software on your PC and adopt the USG, then install the controller permanently on your NAS, the USG will refuse to talk to the NAS.

If that’s the case, you can factory reset the USG so that it becomes ready to be adopted again.

#7

Hi John,

The light is a white when flashing/solid
I dis a hard reset, then Bridge Mode the Telstra modem, ISP to the Unfi gateway WAN, then from gateway LAN to a LAN on the Telstra modem. Switched on Unfi, and waited, solid light, but software did not pick up the Gateway again.

Len

#8

It’s possible that you locked up the communication with your wiring? It’s also possible that I don’t understand the Telstra box as well, though. I believe it should go from Telstra to Gateway WAN. Gateway LAN to the computer… or to a switch and then the computer. Does the Telstra box allow you to go external of the box and then back into it and utilize the internal switch?

#9

You cant feed back to telstra like that… u are making many many problems… remove the Loopback to telstra, reboot everything and see if u have basic web access first…

#10

U have 2 hosting devices fighting for control and probably on very different ip ranges…

#11

U should be able to get the vlan id or other Voip network options from your provider to set up your phone sloution… if ur trying to use the default voip bridge built into the telestra gateway that will not work… u need an external voip converter if ur using conventional landline style phones or get a real IP phone supported by your carrier… if u have any questions feel free to ask…

#12

I run my modem in it’s regular, non-bridged mode, with a router plugged in behind that. Two different sub-nets. Apart from having to set up port forwards on both devices it seems to work fine. Not sure what the day-to-day disadvantages are.

I ended up doing this because I also needed to plug the crap modem Telstra gave me into the better modem I replaced it with to get the home phone. (I also have a Commander SIP phone for work on my home LAN, and the Telstra modem was just not going to handle both.)

§

I really like using DietPi over Raspbian for my Raspberry Pis. Just find the basic install more minimal.

I also try and script as much as I possibly can with Ansible which really makes it so easy to get up and going again fast when something dies or after a disruptive update.

§

Another good, well thought out and easy to follow video with your trademark warmth and sincerity. I really must learn how to fake that! :innocent:

2 Likes
#13

@Len I think @Guru_Of_Nothing and @JacobJohnson are right if your description of the connection is accurate. If you put the modem into bridge mode, you can’t look back into it and use its LAN ports as a switch. The chain should be:

Internet --> Bridge (modem) --> USG --> Ethernet switch --> other devices, including APs

#14

Hi Evan! Nice to see you here :slight_smile:

You can certainly put one router behind another, the only downside is that you end up with double-NAT which can cause problems with MTU settings. It’s many years since I’ve done this, but I had to decrease the MTU size setting on the inner router (I think) to account for the extra bytes prepended to the TCP header with the NAT info. Perhaps modern routers handle that more transparently and easily though.

One known limitation of the USG is when using a Telstra connection with a 4G backup. The USG can use the normal connection without any problems, but the 4G failover has to be double-NATd. Which works, but it adds overhead to every packet by extending the header.

I’ve never tried DietPi. I should give that a go :slight_smile:

#15

Hi All,

Thanks all for responding.
I have hooked the cables a above now.
I can get to this screen, but cannot get past. Any suggestions, or am I on the right path…Len

#16

Perhaps your ISP is using some kind of authentication, such as PAP/CHAP. I haven’t had that on a connection for a long time: normally it’s just a DHCP connection from upstream.

But before we go any further, it’s worth checking whether you still need the Arcadyan LH1000 at all. I’ve never seen one, but looking at images online it seems that the WAN connection on it is Ethernet, which means you probably already have an Ethernet port from your Internet connection. If that’s the case, you don’t need the existing modem as a bridge at all, just unplug the cable that goes into the WAN port of your existing router and plug it into the USG instead.

#17

Hi Jon,
I have ordered a Ubiquiti Cloud Key, to see if I can help.
I would still like to have the Telstra modem, due to the fact it has my Telstra home phone, with 4G phone back up.

If I disconnect the Telstra modem, is there another way to have my home land line connected.

Or I maybe wasting everyone’s time, trying to get the USG connected.
Thanks in advance Len

#18

Hi Len,

I think you’re trying to achieve 2 conflicting things, which is messing you up. You can’t have the original Telstra modem in place providing a phone line while also having it in bridge mode with another router behind it. You need to either use the Telstra provided modem as it’s designed, OR put it into bridge mode (or remove it entirely) and use a replacement router such as the USG. You can’t do both at the same time.

The USG can certainly handle 4G backup if you have a 4G USB device that you can plug into the spare port on the USG. That’s a standard way to use it. But having an old-style landline phone going through it may not be possible unless they’re willing to give you the VoIP configuration details for your account, so you can set it up in a VoIP adapter connected to your landline phone.

#19

Great article/video (as always thanks)

There seems to be various versions of the Ubiquiti APs here in the UK. Given I will need 4 of these, is there a good reason NOT to go for the UAP-AC-LITE WLAN Access Point which is about half the price of the UBI-UAP-AC-PRO? Does the cheaper have management features? Is it all about coverage range?

Thanks!

#20

Hi @talkeasy, welcome!

There’s a brilliant comparison of the various access point models on the Crosstalk Solutions channel, which has many videos related to UniFi gear:

The comparison is about a year old and was done just before the NanoHD was released, but they do another video later which compares the NanoHD to the UAP-AC-Pro.