Vivitar ha-1007-au tasmota

Hello. I’m trying to install Tasmota on my Vivitar ha-1007-au power board. I’m trying to put it in to programming mode. Anything I do doesn’t work. Any help would be greatly appreciated.

You might to provide a few more details about what you have tried. There are a bunch of similar looking devices on Tasmota Templates.

Tasmota Docs about it:

Similar device template with some info:

They all seem to use Tuya convert. But there are some newer devices where they haven’t figured out the encryption scheme. You may need to hold the power button whilst plugging it in, power cycling it 4 times or if there is a reset button, following that process (factory user guide probably has this information).

Tuya-convert worked. Setting up the gpio pins it didn’t have user in the list so I just left it as none. Seemed to work except I don’t get power from any of the sockets. But I do get power from the USB sockets

Short of figuring out what GPIOs are connected, you’ll probably just want to import one of the existing templates. It’s probably also worth uploading the latest tasmota. You’ll have to do minimal first, then full as the firmware that tuya installs initially doesn’t have GZIP support.

Template Imports ->

I set up all the gpio pins. I can see and hear the replays switching the power sockets on and off. But I get no power from the 4 power sockets when they are turned on. I do however get power to the 4 USB sockets. I tried to revert back to the original Vivitar firmware but it gives me a miscompare error.

Do you get power when they’re turned off? It’s possible they require the relay to be inverted (pulled low vs pulled high). This comment seems to show inverted Relay set.

I tried on and off. Neither of them work.

You’d might have to bust out the serial adapter and do some soldering (ensuring mains isn’t plugged in) to revert it. Considering you can hear the relays clicking, it very much sounds like it works, so I’m not sure what’s up. Unless there is a full off/on relay.

I haven’t had the need for a powerboard (at least great enough to justify the price tag), so I’ve yet to play with one. Maybe the Tasmota/Tuya support chats might help? There’s a Tasmota channel on the SuperHouse discord as well :slight_smile: