Uploading firmware (Blink) to Sonoff does not work

I have uploaded the ESP8266 Blink sketch to the Sonoff and it appears to be uploaded successfully. However, the led on the Sonoff does not blink. I have also uploaded a sketch that does a simple serial write but I get nothing in the Serial Monitor.

The Sonoff I am using is this one https://www.ebay.com/itm/6x-Sonoff-ITEAD-WiFi-Wireless-Smart-Switch-Module-Shell-ABS-Socket-for-Home-DIYR/401380242897?hash=item5d742075d1:g:h70AAOSwi0xZ6EQG.

Has the Sonoff changed since the SuperHouseTV #17 video on Youtube, or am I doing something wrong?

I have uploaded a screenshot of the board settings I am using in the Arduino IDE.




Hi Jepean,
I have recently (less than a month) received several Sonoff devices including a basic that you have from Itead directly. I have flashed them with Tasmota without a problem using Arduino with the settings as shown above.

How have you verified that the upload was successful? Is it through the Arduino IDE?


Thank you for your reply! Good to know the flashing of firmware should still work the same way as before. I have not tried uploading Tasmota yet, but I will try that.

Yes, I have only “verified” successful uploading through the Arduino IDE. Maybe the upload has not completed successfully after all? However, something has changed in the Sonoff because the default “setup led blinking” that the Sonoff does out of the box has stopped after the upload.

Best regards,
Jens P.

Ah, if the LED has stopped blinking, then it is certain that the software has uploaded, as the processor stores the new code in the unused half of memory, and once uploaded then it swaps over. You should check that you nominated the correct pin for the LED.

I had problems uploading a few times. Once the first is done, I do the rest over-the-air. That seems to work every time very well.

Thanks for all the kind replys, guys!

I am on a tight schedule these days, but when I get the time I will definitely try uploading Tasmota and then do OTA later if necessary.

Jens P.


Did you resolve this? I’m having the same issue - I can upload to SONOFF basic (Arduino IDE confirms this), but no LED flashing.

I’ve tried many OUTPUT pin combinations to no avail.

Any ideas?


I’m hoping thete will be an answer to this question as well. My Sonoff isn’t showing any sign of life either

I have two Sonoff Dual Channels that need to be updated to TASMOTA. I think I will have time in two weeks. I have a family vacation going on but will try to get to this after and see if I can help out. This is one that I had problems with before and gave up. The regular Sonoff uploads went basically fine.

Hey all,
I used the flash mode DOUT and it worked for me, when I tried DIO it did nothing like you are describing in your post.

I documented my settings on my github page as well as the software that I am running on my sonoffs https://github.com/Lehmancreations/Sonoff-With-MQTT/wiki/Installation