Tasmota & Alexa is it working?

Hi guys,

I have just flashed my first sonoff with the latest Tasmota firmware but I am unable to get Alexa intergration working, I heard a whisper that it no longer works, just wondered if anyone could shed any light on this please.


Being the sort of person who dislikes allowing outside services to directly control my stuff…

I use node-red-contrib-alexa-home-skill and node-red-contrib-nora to let my voice assistants talk to my automation server. Then handle things from there myself.

Hi Tinker,

I dont have a server and nothing to run Node-Red just need to know if the Alexa Emulation still works or not on Tasmota but getting the answer to the question is proving to be quite difficult, I have posted on many forums but all I hear is the wind and tumbleweed


According to the official Tasmota sources…

How can I connect Tasmota devices to Alexa

I never managed to get it to work with ANY version of Tasmota myself.

I am like @Tinker and I use a different Alexa Skill to control my devices because I am running Node Red. However, I know that Tasmota devices can be run as Belkin Wemo emulations using the ‘Configure Other’ tab in Tasmota’s GUI. Configuring Tasmotized devices as Wemo devices is supposed to make them visible as if they were cloned Belkin setups. This is most often used to integrate them in Home Assistant or OpenHab. However, there is a Wemo skill for Alexa that looks for Wemo devices and integrates them. I have not tried it but there is stuff online that is not that old that might help…
Alexa Wemo Smart Plug Setup
Just ignore the setup of the Wemo device in the instructions and go straight to the Wemo skill. If that works well, let us know as I may do some enabling of a couple of my devices that are currently set up in Node Red.

Or, if I had read Tinkers post better (I know… it was simple) and gone to the link he provided… What he said. :upside_down_face:

EDIT: It got me all curious so I tried it. Selected Wemo in Tasmota GUI under other tab and told Alexa to go… Oh sorry :grin: That’s a whole different skill. I told her to discover devices and it picked up the device I set up. Mine is a Tasmotized Shelly1 connected to a light, and was discovered as a ‘plug’ but I think using the Hue Bridge selection may set it up as a light instead. Didn’t try that.