Sonoff WiFi Connectivity Issues


I’m a new Sonoff user and have just flashed my first Sonoff Basic with Tasmota.
An issue that I’m facing, and I’ve found that many people have been reporting is that the sonoff goes offline after initial connection. And some have projects where they are soldering a custom antenna on to the sonoff due to this reason. In my case, I have the sonoff connected to ceiling panel light (metal housing). If I stand directly below the light and check wifi strength on my phone, I see a near perfect signal. But, I think the metal housing could still be causing a signal drop to the sonoff. Its not due to Tasmota because the problem existed even before the flashing.

However, I’m a little skeptical about these antenna mods because, none of the major sonoff tinkering blogs (like SupeHouse), don’t seem to touch on anything of the sort (maybe I just missed it?). So, I’m just curious to hear from someone on this forum whether this is actually a solution or is the problem something entirely different and require a different solution.


I run three sonoffs full time at my house - the only time I had an issue with signal strength was when I zip-tied around the board too close to the antenna. One runs without a secondary enclosure, one is in a 3D printed case, and one is in a repourposed plastic container.


I have a couple in my shed, with my AP in the roof of my house (15 metres away from the shed) and don’t seem to have any issues. No special antenna’s on either the AP or the Sonoffs. I can’t get mobile reception in there if I leave my phone in my pocket, so it’s not exactly ideal conditions.


I should add - the only other time I had issues was when OpenHAB was acting up and they wouldn’t respond. I rebooted OpenHAB and things came back.


Thanks for the replies.
I had even assigned the sonoff a static IP and that didn’t work either.
Out of curiosity, I just ran network diagnostic tool on Windows 10 and it came back saying there are multiple devices on my network doing NAT translation. Perhaps that’s a clue. I’ll investigate that and see if that’s linked to this problem in anyway. I have just gotten a new batch of sonoffs. Their build dates are more recent. I’ll flash tasmota on them as well and see if the old ones were just a bad batch.


Sounds like you might have more than one DHCP server turned on. Check google for a network mapping program. I’m sure there must be quite a few opensource programs floating around. As a mater of fact I just looked and Spiceworks looks like a good candidate
I’m installing it now so I will check back later when I have had a chance to check it out. It’s been a few years since I worked as an network field tech for the Portland Public School System. I was the guy who went out and kept everything running in 200+ buildings and did WiFi surveys in my spare time. I retired in 2009 so I’m a bit rusty but you know what they say about bicycles and networks. :stuck_out_tongue_winking_eye: