Sonoff Mini not visible on Wifi

I purchased 2 Sonoff minis and connected the first to a light switch , then attempted to connect them to my 2.4GHz wifi and it was not visible on my phone or on my laptop and I could not pair with eWelink. Any ideas?

Hi, IIRC the sonoffs default to an address in the range I can’t recall exactly. If you check the docs they will probably give you the default address. Actually I think if you get your wifi to look for an access point you should see a site or 2 starting with Sonoff.


I had similar problems getting my 5 new R3 Basics to pair on my wifi. I found that even though I had disabled the 5G on my Telstra gen 2 router, the 5G radio signal was still active under a separate tab. Once I disabled that, pairing the 5 new devices & 2 Mini’s was straight forward.

I don’t have Sonoff Mini. But I would assume all Sonoff device wifi cards are the same. I have Linksys smart router that default with 10.x.x.x and not 192.x.x.x. My Sonoff basic devices are fine with 2.4G connection without any issue. It could be your router issue more than Sonoff device issue.

Hi Ducky,
I have tried to pair the sonoffs on 2 different Wifi networks with 2 completely different routers, I will try disabling the 5GHz network and see if that works

I disabled the 5G on my router but I still could not pair the mini. I don’t know how to determine if there is still a 5G radio signal under a different tab?

I don’t have access to my router at the moment but will get back to you over the w/e.
In the meantime, are you using a Telstra gen 2 modem?

I have tried 4 different modems on 4 different networks, Vodafone, TP Link, Telstra and Netgear and the pairing times out on each one. On a more recent note I purchased a different brand of switch called Smart Life which on the outside looks identical to the Sonoff and that worked without any problem at all with the smart life app

AyDee, Not sure what you can do from there! The Telstra setting I was talking about is in the wifi page of advanced settings - open the wifi radio tab & uncheck the 5GHz radio box. Once I did that, I could pair the Sonoff’s.
Good luck. Let us know if you manage to succeed & how.

Success. I am still unable to connect in basic pairing mode but as a result of the documentation from the Smart Home switch I found out that in Alternative Pairing mode the flashing blue light flashes differently so when I put the Sonoff in AP mode I was able to pair over the settings in WiFi and now eWelink works just fine.
Thanks for all your help everybody