Openhab2 to Home Assistant

#1

Hi all,

Thought I’d give a quick note as I’ve taken the plunge and moved from OH2 to HA. I did try HA a year or 2 back but wasn’t overly happy with the UI so went with, at that stage the new OH2.
Fast forward to 2 or 3 months ago and I decided to try HA as a docker after watching ‘State of the Union’ which was great to see some direction and understand the project better.

The tipping point for updating production to HA was using the new LoveLace UI which is getting better and better:

Rules were another point, I really liked using NodeRed with OH2 and initially wasn’t sure on HA, struggling a bit… but after READING the manual on the automation functionality things fell into place (who would have thought :grin:) and I quite like it although I’ve only done relatively simple stuff so far. HA does have NodeRed plugin but I haven’t tried that yet.

Which one to use will really come down to personal preference but I have to say I don’t have problems like I used to, I felt like I was constantly hitting issues or bugs with OH and it’s plugins (maybe me?) but HA just works. If you are looking for a new system I’d highly recommend checking it out.

Keen to hear what others think of the 2 systems.

#2

I started out with OH2 and got quickly frustrated with contradicting documentation. My main task I was trying to accomplish was adding an MPD player and after seeing over and over again that MPD was supported but not finding it on the extensions I finally found that it was supported for OH1 and even though it was in OH2’s documentation it wasn’t supported and wasn’t (currently) going to be ported.

Within minutes of having HA installed (manual install on raspbian) I had a working MPD player.

The more time I’ve spent with HA I’ve enjoyed it. I’ve found a couple limitations in the UI and at least one straight-up bug but most I’ve been able to work around. I may spend some time with it over the next couple weeks and see if I can write up some pull requests and fix some of the code.

#3

About 3 years ago when I jumped off the deep end and started using OH on top of my existing homebuilt system, the big turnoff (if I remember correctly) was that only OpenHab had good cloud connection options. My own system was fine for what I wanted while I was home, but I didn’t want to mess with opening ports to the WWW and I didn’t want to build my own app. That may have changed more recently…

I will openly admit that the OpenHab programming interface is essentially non-existent and very clunky in SmartHome Designer. I loath having to crate CRON jobs for timing… I’d love to just have a calendar interface or something like scheduling recurring meetings in Outlook for scheduling tasks.

#4

I been using OpenHab2 for a little bit, I must admit the documentation is frustrating sometimes, but with the PaperUI I have managed to do most things I need with the Rule, MQTT addons.

I am very interested in HA though as it has seem to improve in leaps and bounds and with NodeRed seems to provide a powerful solution. I giving myself another 12 months playing with OH2 and when we renovate I will decide then if I need to switch as I will have a ton more things to control.

#5

I am at THAT point right now and I am about to launch this Pi out of the window. Forcibly. With glee. I can’t get either OH or Hass-io to install. Like not at all. Both give me errors that seem to be very common when doing the jazz hands routine on Gargler (Google search… it’s an AvE thing). I have toyed with doing the manual install of HA on Raspbien but I understand it is finicky and I don’t know Linux. At all. Hence why I wanted a basically plug and play (or flash and insert) install. I REALLY want to learn Linux stuff and utilize these 4 Pi3b’s that I own and can’t seem to get anything but Raspbien working on but holy crap! What a frustration! I hate Windows with a passion but it seems that everything I touch that is Linux is just a pig. And that is probably because I don’t know anything about it, so as to fix it when it’s being lumpy.

Any suggestions? Not in the technical support end but in a specific direction?

#6

I used these instructions: https://www.home-assistant.io/docs/installation/raspberry-pi/

I installed it on a raspbian “stretch” lite. I think there was one command that failed with a timeout and I simply ran it again.

#7

OK. I will take a whack at that. The trouble we go through to turn a light off and on:0)

1 Like
#8

Have you tried a different sd card, I’ve hit issues in the past installing only to find card was stuffed.

Is this page what you were using for hassio image?

So all 4 pi’s result in same error?

#9

Same site… 32 bit installer. I tried 2 different Pi’s and 3 different SD cards. EXACT same error.

My latest post to the OpenHabian forum…
https://community.openhab.org/t/probably-beating-a-topic-to-death-openhab-wont-load-git/69160

#10

If you try HomeAssistant again from the link I sent y ou and still have issues direct-message me the details and I can try and help you get through the install. I did it less than 2 weeks ago, and even went through the update yesterday.

#11

I have not tried HA as a manual install to Stretch. Just Hass-io. I will try it tonight and let you know if I have issues. Appreciate it. I would love to get an OH install running on another Pi and may still get after that as well but I am just trying to get SOMETHING working so I can start building automation items to play with. Got a soldering iron just itching to get warmed up!

#12

Could also try brurning using https://sourceforge.net/projects/win32diskimager/
And maybe using a different machine? Rule everything out :slight_smile:

#13

So… that was an adventure. The short of the long of it is that indeed, a 5v 2.5A wallwart is not what it was advertised. I bought a 12v to 5v buck converter with USB output on it… rated at 5A mind you… and hooked it up to my 12v (13.8v actually) PSU and OpenHabian is actually loading and doing the do such as it should. Then to add insult to injury, the switch I was using for the network connection to the Pi’s I was trying to set up is goofed up and giving me fits. I got a tad bit grouchy and decided that it was time to put on my big boy pants and buy some reliable gear. I purchased 3 Ubiquiti wifi pucks (the Lite version, not the pro. Not made of money :grin: ) and will replace all three of my routers that are doing A/P duty. Also ordered a new 5 port switch to put here on the bench of death so I don’t have to keep plugging and unplugging the network cables from my computer to use on the Pi’s and what not. Maybe now that I am done with all the shenanigans, I can actually get to doing automation projects? Nope. Boss just extended the open overtime for 2 more weeks. Daddy needs a new digital microscope!!!

#14

Timing! I’m recording an episode now about how to set up WiFi for home automation the right way, and I’m using Ubiquiti gear for it :slight_smile:

1 Like
#15

Brilliant, I have just received an outdoor Ubiquiti AP. perfect timing.

#16

I am a big Home-Assistant “preacher” i have been using it over 2 years now and am closely following the evolution here is my github with some screenshots. all the icons on the floor-plans are actionable via touch.
There has also been some side Projects like ESPhome (an easier way to "flash ESPs with yaml) The community is huge and growing.
We have actionable ios notifications and we can pus camera streams : https://youtu.be/l9eBRNBf5Zg

I’ve tried OpenHab but quickly got frustraed so i moved to HA and never looked back.

#17

Admittedly, I am frustrated with ALL of it. My problem is that I have only recently gotten in to the Linux environment and not having GUI access to manipulate all of the things involved really handicaps me. I have spent a lot of time now trying to just get the base things installed and working as scratch installs… OH2 and HA… and Openhab I got installed but the GUI parts that do the rules and things database management is still very much in its infancy and not very intuitive and makes little sense to me. I was able to install Stretch Lite and follow line by line the way to do a manual install of HA but couldn’t make heads nor tails of how to make it a service so it would come up on power up instead of having to go in and restart everything (that I never figured out how to do BTW). My time to do this hobby is quite limited and I find I spend too much time making absolutely nothing work. I refuse to give up on it but if I can’t get the backbone to work (it’s my understanding of the product, not the product itself) it’s pointless to make the projects to automate which is what I most want out of all this. I am ready to scrap OH and go to HA but super frustrated with my lack of Linux abilities. I should have been into this 20 years ago when my brain was a sponge to this kind of thing.

#19

While I have a server running unraid and had HA as a docker (along with Domoticz and OH), for my permanent setup I got my rpi, burned hassio booted it up and had HA running in very little time. You shouldn’t need Linux experience 99% of the time I think, everything is configured through GUI.

I’ve kept it separate to the main sever partly due to this simplicity of HASSIO, it just works and has been for 12+ months. Saw your other post about having power hungry server not doing anything, RPi uses a few watts so unless you have a reason to run the other server 24/7 I’d be saving power running server and use the rpi :slight_smile:

2 Likes
#20

If you have a Spare Pi & SDCard that is all you need to get started with Home-Assistant. I have no knowledge whatsoever of Linux and i have it working pretty fine.

I was Running on a Pi for a long time but moved to NUC since i was useing a lot of ADD-ONS. Since then again they have made Home-Assistant quicker and lighter. So you should be fine Running on a Pi.

Hers is a Link on how to get started :

Once up and running it should automatically find some devices

If you have other Questions do not hesitate to write me up and i will help you

#21

Thank you @adonno I downloaded the current version of Hassio and formatted and flashed it to a card using Etcher. Plugged it in a spare Pi and let it run. Will check on it tonight when I get the free time to take a look. When I last tried to install, I was having switch problems but have since resolved it. MAYBE this time we will have a go?